View Issue Details

IDProjectCategoryView StatusLast Update
0012998Tine 2.0Tinebase JavaScriptpublic2018-01-12 09:54
ReporterschwigiAssigned Tocweiss 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.02.3 Community Edition 
Target Version2017.08.11 Community EditionFixed in Version2017.08.11 Community Edition 
Summary0012998: Hammerjs does not load
DescriptionOn my new Windows 10 tablet hammerjs gets not loaded propperly. This results in the calendar and addressbook not working.

On the tablet this is reproducible on the tablet with Chrome, Edge and Firefox on Windows 10 and with Firefox running Ubuntu.

On all other systems I've tested (Windows 7, Windows 10, Ubuntu with Chrome and Firefox) all without a touchscreen.

Since my tablet is the only device with a touchscreen available and hammerjs is supposed to be a touch gesture library my guess is that this is reproducible on other touch screen devices as well.
Steps To ReproduceUse a device with a touchscreen and use the tine20 webinterface.
Additional InformationThe Server is running tine in a subdirectory

https://<servername>/tine20 on an Ubuntu 16.04 LTS
TagsNo tags attached.
mwticket

Relationships

related to 0013430 resolvedcweiss Calendar: printing day and week sheet broken in FF 

Activities

schwigi

schwigi

2017-05-02 18:56

reporter  

browser_consolelog_1493744098243.log (4,740 bytes)
ingoratsdorf

ingoratsdorf

2017-05-03 04:56

developer   ~0019984

I can confirm the issue with windows10 on a SurfacePro3 and any browser.
I have all popup windows on my surface as modal windows even though I did select browser windows and they appear 2x or 3x on top of each other.
Using my laptop (same OS, same browsers) I get the standard browser windows and all work fine.
mspahn

mspahn

2017-05-03 18:01

administrator   ~0019994

Last edited: 2017-05-03 18:02

View 2 revisions

Are you running dev versions? In case you are not using our prebuild packages you need to run npm install inside Tinebase/js

Also please check your browser support:
http://hammerjs.github.io/browser-support/

schwigi

schwigi

2017-05-03 18:34

reporter   ~0019998

I am running the packaged ubuntu version from xenial stable. So no current dev changes should be a problem.

The browsers I used (Desktop Firefox, Desktop Chrome) are all supported and should not result in a load error or strange behaviour without using touch gestures. Using an ASUS T101HA Tablet with Dock attached.

If it helps I can set up an npm version in parallel.
hobbyist

hobbyist

2017-08-15 00:31

reporter   ~0020606

Hey, some TInebase/js-libraries, e.g. OpenLayers-f5fc191258fd529b739f-FAT.js or linkify, can't be loaded for me either. In my case, Tinebase/js is linked to the /-docroot-directory, whereas tine 2.0 is installed in a subdirectory-path. Maybe that's also your problem with hammerjs not working?!

Providing a /TInebase/js in the webserver's docroot-directory, is a ugly, but functional workaround. Maybe I try a rewrite.
estradis

estradis

2017-08-18 15:52

reporter   ~0020614

Problems with hammer.js also observed in https://forge.tine20.org/view.php?id=13142 (See screenshot)
hobbyist

hobbyist

2017-08-18 16:22

reporter   ~0020616

But as you can see in post https://forge.tine20.org/view.php?id=13142 , this installation is also located in a subdirectory-path named /tine20
estradis

estradis

2017-08-24 09:11

reporter   ~0020620

@hobbyist: Not sure what you want to tell me. What exactly is the problem and what exactly have I to do to fix it?

FYI:
We installed tine as described in https://wiki.tine20.org/Admins/Install_Howto on an ubuntu server. The path came from the original installation with apt. Tine is hosted in our dmz, but not accessible directly. It can only be reached through our reverse proxies with loadbalancers. Our webservers are hardened as well as the proxies with the loadbalancers.
We welcome the installation inside a subdirectory because it makes the configuration of the loadbalancers much easier. Konfigurations at root level is possible, but not recommend because it may break our hardening. (Our servers will only respond on the correct hostheaders *AND* subpaths. All other request will result into 403, 404, 410.)
hobbyist

hobbyist

2017-08-27 10:43

reporter   ~0020622

Hi,
@estradis I don't want to give you an advice, I want to help solving the problem by describing the cause. I observed, that some JS-Files in that folder, where hammerjs resides, aren't adressed correctly by tine 2.0, when you using a subdir-installation, as it tries to load them from the webserver's root directoy, understandably failing with a 404 error. You referred to a ticket, whose screenshots supports my theory. As you recently added, you also use a subdir-installation for the ease of loadbalancing and reverse-proxying.

So, if you asked me for an advice or a quick fix, I would recommend you to think about whether you can afford/want (in your environment) to provide that /TInebase/js-directory additionally in https://yourdomain.org/Tinebase/js, cause that's the place your https://yourdomain.org/tine20/-installation is looking for those scripts, or try a rewrite of that paths.

Otherwise you have to wait, till the adressing of that components is fixed by the developers.

So, no offence meant, maybe that will help you to decide or solve your problems.
estradis

estradis

2017-08-28 14:07

reporter   ~0020624

Hi Hobbyist,

Now I almost feel a bit ashame because I didn't get it myself. (We had some infrastructure incidents in a HA environment, therefore the whole team had a lot of overload to troubleshoot. Maybe that was the reason.)

Thank you for your recommendation. I appreciate it! Your example looks very good. We should be able to uphold our hardening by using Tinebase as an alternate subpath. We'll investigate this and report as soon as we have the results.
estradis

estradis

2017-08-31 17:18

reporter   ~0020628

Hi Hobbyist,

your recommendation works very good and our hardening is not broken.
(Details in https://forge.tine20.org/view.php?id=13142)

Thank you again. You made my day!
cweiss

cweiss

2018-01-12 09:53

administrator   ~0021318

same problem as 0013430 should be fixed if it was still a problem for some

Issue History

Date Modified Username Field Change
2017-05-02 18:52 schwigi New Issue
2017-05-02 18:56 schwigi File Added: browser_consolelog_1493744098243.log
2017-05-03 04:56 ingoratsdorf Note Added: 0019984
2017-05-03 18:01 mspahn Note Added: 0019994
2017-05-03 18:02 mspahn Note Edited: 0019994 View Revisions
2017-05-03 18:34 schwigi Note Added: 0019998
2017-08-15 00:31 hobbyist Note Added: 0020606
2017-08-18 15:52 estradis Note Added: 0020614
2017-08-18 16:22 hobbyist Note Added: 0020616
2017-08-24 09:11 estradis Note Added: 0020620
2017-08-27 10:43 hobbyist Note Added: 0020622
2017-08-28 14:07 estradis Note Added: 0020624
2017-08-31 17:18 estradis Note Added: 0020628
2018-01-12 09:53 cweiss Relationship added related to 0013430
2018-01-12 09:53 cweiss Assigned To => cweiss
2018-01-12 09:53 cweiss Status new => resolved
2018-01-12 09:53 cweiss Resolution open => fixed
2018-01-12 09:53 cweiss Fixed in Version => 2017.08.11 Community Edition
2018-01-12 09:53 cweiss Note Added: 0021318
2018-01-12 09:54 cweiss Target Version => 2017.08.11 Community Edition