View Issue Details

IDProjectCategoryView StatusLast Update
0013166Tine 2.0Setuppublic2018-03-22 17:42
ReporterestradisAssigned Topschuele 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status newResolutionopen 
Product Version2017.02.3 Community Edition 
Target VersionFixed in Version 
Summary0013166: Fatal error: Uncaught exception 'Setup_Exception_NotFound' with message 'Projects/Setup/setup.xml not found.
DescriptionAs already described in the community, we had some issues with the Projects application when using setup.php --backup.
See full report and details at
Steps To ReproduceAs the Projects Application was deinstalled, this issue cannot be reproduced any more.


(Projects is installed but files are no longer in tine20 dir)

/usr/bin/php /usr/share/tine20/setup.php --config /etc/tine/ --backup -- config=1 db=1 files=1 backupDir=/home/estradis/backup/ noTimestamp=0

-> Fatal error: Uncaught exception 'Setup_Exception_NotFound' with message 'Projects/Setup/setup.xml not found. If application got renamed or deleted, re-run setup.php.' in /usr/share/tine20/Setup/Controller.php:476
Stack trace:
#0 /usr/share/tine20/Setup/Controller.php(2077): Setup_Controller->getSetupXml('Projects')
#1 /usr/share/tine20/Setup/Controller.php(2048): Setup_Controller->_getBackupStructureOnlyTables()
0000002 /usr/share/tine20/Setup/Frontend/Cli.php(721): Setup_Controller->backup(Array)
#3 /usr/share/tine20/Setup/Frontend/Cli.php(82): Setup_Frontend_Cli->_backup(Object(Zend_Console_Getopt))
0000004 /usr/share/tine20/Setup/Server/Cli.php(114): Setup_Frontend_Cli->handle(Object(Zend_Console_Getopt))
#5 /usr/share/tine20/Setup/Core.php(115): Setup_Server_Cli->handle()
#6 /usr/share/tine20/setup.php(14): Setup_Core::dispatchRequest()
Additional InformationAs we aren't using Projects application in Tine, the quick and dirty workaround is acceptable for me. I opened this issue because I was adviced to do it.
TagsNo tags attached.


related to 0013142 resolvedpschuele Severe Display Problems in Tine 




2018-03-11 07:47

reporter   ~0021492

Hello, I ran into this problem too and followed the steps from the forum to "fix" it. But I'm pretty sure the Projects application was not installed (or disabled in the admin settings, not sure where this is the same..) before the upgrade


2018-03-12 10:04

reporter   ~0021494

Meanwhile it also affected these modules:
- HumanResources
- Inventory

As we don't use them on tine, we also uninstalled them.


2018-03-13 14:45

administrator   ~0021500

Well, we just removed them from the all-in-one package. You download them from github. Does that fix your problem?


2018-03-14 09:48

reporter   ~0021508

We were never focused on them any more, so we can't say. I will observe it on our next update and report the result then.


2018-03-19 09:14

reporter   ~0021542

I updated tine with the latest available all-in-one package from github yesterday. There were no Projects, HumanResources or Inventory Modules included. These directories are missing as well.

As I already wrote above, we don't use them, so it's ok for us.


2018-03-22 17:42

administrator   ~0021564

I'll have a look into this. maybe there is a way to make this more robust.

Issue History

Date Modified Username Field Change
2017-06-01 13:45 estradis New Issue
2017-06-01 18:19 pschuele Relationship added related to 0013142
2017-06-02 08:31 pschuele Description Updated View Revisions
2017-06-02 08:31 pschuele Steps to Reproduce Updated View Revisions
2018-03-11 07:47 tob Note Added: 0021492
2018-03-12 10:04 estradis Note Added: 0021494
2018-03-13 14:45 mspahn Note Added: 0021500
2018-03-14 09:48 estradis Note Added: 0021508
2018-03-19 09:14 estradis Note Added: 0021542
2018-03-22 17:41 pschuele Assigned To => pschuele
2018-03-22 17:42 pschuele Note Added: 0021564