View Issue Details

IDProjectCategoryView StatusLast Update
0013350Tine 2.0Tinebasepublic2017-08-03 11:55
ReporterhobbyistAssigned Topschuele 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.02.5 Community Edition 
Target Version2017.08.1 Community EditionFixed in Version2017.08.1 Community Edition 
Summary0013350: Redis-Actionqueue isn't working anymore
DescriptionJobs e.g. invitations are not sent via redis-actionqueue anymore. The execution of jobs failed and jobs are re
Additional InformationSince your rework of the actionqueue's code in 0013220 until now (https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/blob/90d96d1143f7ccedbf554a86330578a43d1df456/tine20/Tinebase/ActionQueue/Worker.php) you do a check whether the function returns any other value than a boolean true: if (true !== ($result = Tinebase_ActionQueue::getInstance()->executeAction($job))) {

In class ActionQueue.php (https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/blob/master/tine20/Tinebase/ActionQueue.php#L135) you return the results of function call_user_func_array (return call_user_func_array(array($controller, $actionName), $message['params']);)

which according to the PHP-reference returns a boolean false, if an error occured, but a mixed result, if the function was executed correctly.

For example when you fork the Calendar.sendEventNotifications controller-method, you return void in method sendNotificationToAttender of class EventNotification (https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/blob/master/tine20/Calendar/Controller/EventNotifications.php#L270) which is passed back. The test of a boolean true fails and the job will be rescheduled.

So actually, ActionQueue isn't working for me any more.

Maybe the bevaviour described in issue 0011512 is caused by that bug.

Am I wrong or would be if (false === ($result = Tinebase_ActionQueue::getInstance()->executeAction($job))) the better solution? At least I got a success running the jobs (although I don't get mails - but maybe that's caused by my weird config).
TagsNo tags attached.
mwticket

Relationships

related to 0011512 new Tine sends every minute calendar invitations 

Activities

pschuele

pschuele

2017-07-21 09:55

administrator   ~0020516

thanks for the report, we'll have a look!
hobbyist

hobbyist

2017-07-29 14:10

reporter   ~0020522

issues 0011512 and 0013350 are now discussed in the forum on topic https://www.tine20.org/forum/viewtopic.php?f=12&t=18506

Why Mail weren't sent was simply because I forgot to install a postfix after changing my Server. :-(
Nevertheless the actionsqueue's success checks should be reviewed.
pmehrer

pmehrer

2017-08-02 17:03

developer   ~0020536

thanks for reporting this. The code in that region has changed in the meantime, so this issue is not present anymore

best regards
Paul

Issue History

Date Modified Username Field Change
2017-07-20 19:22 hobbyist New Issue
2017-07-21 09:54 pschuele Relationship added related to 0011512
2017-07-21 09:55 pschuele Note Added: 0020516
2017-07-29 14:10 hobbyist Note Added: 0020522
2017-08-02 17:03 pmehrer Note Added: 0020536
2017-08-02 17:03 pmehrer Assigned To => pschuele
2017-08-02 17:03 pmehrer Status new => resolved
2017-08-02 17:03 pmehrer Resolution open => fixed
2017-08-03 11:55 pschuele Fixed in Version => 2017.08.1 Community Edition
2017-08-03 11:55 pschuele Target Version => 2017.08.1 Community Edition