View Issue Details

IDProjectCategoryView StatusLast Update
0013386Tine 2.0MailFilerpublic2017-09-20 13:51
ReporterapvitAssigned Topschuele 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.02.3 Community Edition 
Target Version2017.08.5 Community EditionFixed in Version2017.08.5 Community Edition 
Summary0013386: Improve loading performance
DescriptionProblem:
In Folder with many records, it takes quite long to load the list of records. When working a lot with mailfiler this is time consuming and annoying.

Reason:
When selecting a folder, Tine is loading not only the data to display the list (from the database), but the complete messages (from the filesystem) - although most of the data is not needed. When the page has 100 messages this can take quite a while. But even with 25 messages the response time is awful slow.

Proposed solution:
When creating the message-list, only the data needed for the list should be loaded. Fore this, only the database is needed, which should be fast.
For the messages, there are two possibilitis
- load messages in the background after the list has been loaded and displayed.
- load message only when user cklicks on a record in the list (preferred, because less data needs to be transferred).
TagsNo tags attached.
mwticket

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-08-11 12:18 apvit New Issue
2017-08-11 12:19 apvit Summary Improve performace of => Improve loading performace
2017-09-14 12:56 pschuele Category Filemanager => MailFiler
2017-09-14 12:56 pschuele Assigned To => pschuele
2017-09-14 12:56 pschuele Summary Improve loading performace => Improve loading performance
2017-09-18 12:36 pschuele Target Version => 2017.08.5 Community Edition
2017-09-19 18:22 pschuele Status new => gerrit
2017-09-20 13:51 pschuele Status gerrit => resolved
2017-09-20 13:51 pschuele Resolution open => fixed
2017-09-20 13:51 pschuele Fixed in Version => 2017.08.5 Community Edition