View Issue Details

IDProjectCategoryView StatusLast Update
0013406Tine 2.0Setuppublic2017-09-11 14:13
ReportercsvarerAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionwon't fix 
Product Version2017.08.3 Community Edition 
Target VersionFixed in Version 
Summary0013406: Crash when trying to upgrade database from 2017.02.05 to 2017.08.03
DescriptionHi
I have just tried to upgrade between the two versions mentioned above. Unfortunately, the upgrade of the database doesn't succeed but crashes in the middle of the update process with a message like:

neuro:/home/srv/www/vhosts/tine # php setup.php --update
PHP Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`tine20db`.`#sql-230e_4`, CONSTRAINT `tine20_container_content::container_id--container::id` FOREIGN KEY (`container_id`) REFERENCES `tine20_container` (`id`) ON DELETE CASCADE)' in /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement/Pdo.php:228
Stack trace:
#0 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement/Pdo.php(228): PDOStatement->execute(Array)
#1 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement.php(303): Zend_Db_Statement_Pdo->_execute(Array)
0000002 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Adapter/Abstract.php(480): Zend_Db_Statement->execute(Array)
#3 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(' in /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement/Pdo.php on line 235

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`tine20db`.`#sql-230e_4`, CONSTRAINT `tine20_container_content::container_id--container::id` FOREIGN KEY (`container_id`) REFERENCES `tine20_container` (`id`) ON DELETE CASCADE)' in /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement/Pdo.php:228
Stack trace:
#0 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement/Pdo.php(228): PDOStatement->execute(Array)
#1 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement.php(303): Zend_Db_Statement_Pdo->_execute(Array)
0000002 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Adapter/Abstract.php(480): Zend_Db_Statement->execute(Array)
#3 /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(' in /home/srv/www/vhosts/tine/vendor/zendframework/zendframework1/library/Zend/Db/Statement/Pdo.php on line 235

do you have an idea of how to correct for that?

Best regards
Claus
TagsNo tags attached.
mwticket

Activities

csvarer

csvarer

2017-09-11 09:49

reporter   ~0020662

I got the idea that it perhpas helped deleting the files in the cache, session and tmp files before trying the update and it did. I don't know if it was because I did run the "php setup.php --update" as root where the apache server that normally uses these files is runned as the apache user "wwwrun", but it helped and vers 2017.08.3 is running åerfectly well
csvarer

csvarer

2017-09-11 09:51

reporter   ~0020664

As described in note, solution was to delete the files in cache, session and tmp directories before running the database update script
pschuele

pschuele

2017-09-11 14:13

administrator   ~0020666

ok, thanks for the update. we'll think about adding the clearing if cache/session/tmp to the update process, too.

Issue History

Date Modified Username Field Change
2017-08-29 23:08 csvarer New Issue
2017-09-11 09:49 csvarer Note Added: 0020662
2017-09-11 09:51 csvarer Status new => closed
2017-09-11 09:51 csvarer Resolution open => won't fix
2017-09-11 09:51 csvarer Note Added: 0020664
2017-09-11 14:13 pschuele Note Added: 0020666