View Issue Details

IDProjectCategoryView StatusLast Update
0013582Tine 2.0CalDAVpublic2017-11-09 14:48
ReporterlhitcAssigned Topschuele 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformCore i7 NotebookOSLinux MintOS Version18.2
Product Version2017.08.8 Community Edition 
Target Version2017.08.9 Community EditionFixed in Version2017.08.9 Community Edition 
Summary0013582: Tine sends an invalid VTODO during sync, when a task is marked as done
DescriptionI'm using DAVdroid for syncing my Android device with Tine.
When I mark a task as done in the Tine web UI, that is not synced to the device.
Marking the task as done on the Android device syncs fine.
Everything else is also syncing fine.

I first reported this as a bug to DAVdroid, but apparently Tine is the source of the problem for being non-conformant to the relevant RFC.
For details see https://forums.bitfire.at/topic/1567/marking-a-task-as-done-doesn-t-sync-from-tine-2-0-server-to-phone
Steps To Reproduce1. create an unfinished task in the Tine web UI
2. sync CalDAV data to the Android device (sync app is DAVdroid, Google Playstore version)
3. the task appears correctly on the Android device
4. set the task to "done" in the Tine web UI
5. sync again
6. the task is still marked as unfinished
Additional InformationPlease note that changing the Android DAV sync app is not an option, since DAVdroid is currently the only one working correctly in background with Android 7.
Tagscaldav
mwticket

Activities

ingoratsdorf

ingoratsdorf

2017-10-25 21:26

developer   ~0021042

Last edited: 2017-10-25 21:31

View 2 revisions

Hi,
I can confirm that Tine20 sets the COMPLETED property incorrectly as a local time with TZID. According to the spec, this should be in UTC, unlike DUE which should be local if the DTSTART is local. I'd call this inconsistency, but that's what it is.
COMPLETED Ref: https://tools.ietf.org/html/rfc5545#section-3.8.2.1
DUE Ref: https://tools.ietf.org/html/rfc5545#section-3.8.2.3

Interestingly enough, it passes iCalendar validator.
Ref: https://icalendar.org/validator.html#results

I believe the fix is easy and I'll try to get this done ASAP.

ingoratsdorf

ingoratsdorf

2017-10-28 10:08

developer   ~0021050

Created https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/pull/34
pschuele

pschuele

2017-11-09 13:57

administrator   ~0021102

thanks for the PR. we'll review that soon.
pschuele

pschuele

2017-11-09 14:48

administrator   ~0021106

Last edited: 2017-11-09 14:48

View 2 revisions

change has been merged :)

Issue History

Date Modified Username Field Change
2017-10-25 20:12 lhitc New Issue
2017-10-25 20:12 lhitc Tag Attached: caldav
2017-10-25 21:26 ingoratsdorf Note Added: 0021042
2017-10-25 21:26 ingoratsdorf Assigned To => ingoratsdorf
2017-10-25 21:31 ingoratsdorf Note Edited: 0021042 View Revisions
2017-10-28 10:08 ingoratsdorf Note Added: 0021050
2017-10-28 10:09 ingoratsdorf Status new => assigned
2017-11-09 13:57 pschuele Note Added: 0021102
2017-11-09 13:58 pschuele Assigned To ingoratsdorf => pschuele
2017-11-09 13:58 pschuele Status assigned => gerrit
2017-11-09 13:58 pschuele Target Version => 2017.08.9 Community Edition
2017-11-09 14:48 pschuele Note Added: 0021106
2017-11-09 14:48 pschuele Note Edited: 0021106 View Revisions
2017-11-09 14:48 pschuele Status gerrit => resolved
2017-11-09 14:48 pschuele Resolution open => fixed
2017-11-09 14:48 pschuele Fixed in Version => 2017.08.9 Community Edition