View Issue Details

IDProjectCategoryView StatusLast Update
0013584Tine 2.0Tinebasepublic2017-11-11 16:43
Reporterlab-at-nohlAssigned Topschuele 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.08.8 Community Edition 
Target Version2017.08.9 Community EditionFixed in Version2017.08.9 Community Edition 
Summary0013584: Enhancement of 0011236: Smtp-Backend simpleMail should remove remaining user data
DescriptionSimpleMail is used to store additional mail routing data in LDAP outside user‘s DN. In default configuration: mailAlternateAddress, mailForwardingAddress and mailDiscard. This is especially handy if mail settings originate from an other tool (which may use different attribute‘s name than default configuration).

If the user‘s Account is deleted the mail routing data remain because it is outside the removed DN. I guess that is why the trigger „inspectDeleteUser“ isn‘t implemented in LDAP-Plugins.

My last pull request https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/pull/30 connects the trigger and execute it as inherited function wehen user gets deleted.
Additional InformationI put the changes into two different commits that you can evaluate commit a002438 separately because this changes Tinebase/User/Ldap.php and Tinebase/User/Plugin/LdapAbstract.php slightly. The reason is that ldap plugins (sync backends) didn't offer a trigger if an user is deleted (unlike SQL backends do). I added one hopefully in a way that does not interfere with the other plugins: The added function is limited to an empty abstract of class, therefore only those classes which need it may inherit the additional function (other Plugins stay untouched).

I think the nature of change makes it a candidate for a late minor update.
TagsNo tags attached.
mwticket

Relationships

related to 0011236 resolvedlab-at-nohl Feature: SMTP Backend handling "simpleMail" and other LDAP schemata 

Activities

pschuele

pschuele

2017-11-09 17:12

administrator   ~0021110

hi Johannes, thanks for your PR (https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/pull/30).

we'll put that into the gerrit for autmated testing and will review it soon.

Issue History

Date Modified Username Field Change
2017-10-26 14:29 lab-at-nohl New Issue
2017-10-26 14:29 lab-at-nohl Relationship added related to 0011236
2017-11-09 17:12 pschuele Note Added: 0021110
2017-11-09 17:12 pschuele Assigned To => pschuele
2017-11-09 17:12 pschuele Status new => gerrit
2017-11-09 17:12 pschuele Product Version 2017.08.9 Community Edition => 2017.08.8 Community Edition
2017-11-09 17:13 pschuele Description Updated View Revisions
2017-11-11 16:43 pschuele Status gerrit => resolved
2017-11-11 16:43 pschuele Resolution open => fixed
2017-11-11 16:43 pschuele Fixed in Version => 2017.08.9 Community Edition