View Issue Details

IDProjectCategoryView StatusLast Update
0013596Tine 2.0Felamimailpublic2018-03-01 17:32
ReporterapvitAssigned Topschuele 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2017.08.8 Community Edition 
Target VersionFixed in Version 
Summary0013596: Error "Character not in repertoir" when fileing message (PGSQL)
DescriptionError message:

 2018-01-11T08:31:50+00:00 NOTICE (5): Felamimail_Controller_Cache_Message::_addMessageToCache::918 failed to add message to cache: SQLSTATE[22021]: Character not in repertoire: 7 FEHLER: ungültige Byte-Sequenz für Kodierung »UTF8«: 0xe5, query was: INSERT INTO "t20_felamimail_cache_message" ("account_id", "messageuid", "folder_id", "received", "size", "timestamp", "body_content_type", "content_type", "subject", "sent", "from_email", "from_name", "text_partid", "html_partid", "has_attachment", "id") VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, 1, 2, 0, ?)

same here in Mailfiler

Fehler beim Speichern von Nachrichten
SQLSTATE[22021]: Character not in repertoire: 7 FEHLER: ungültige Byte-Sequenz für Kodierung »UTF8«: 0xc2, query was: INSERT INTO "t20_notes" ("note_type_id", "note", "record_id", "record_model", "record_backend", "id", "created_by", "creation_time", "last_modified_by", "last_modified_time", "is_deleted", "deleted_time", "deleted_by", "seq") VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)

Log:
41787 eb - 2017-10-31T07:38:08+00:00 ERR (3): Tinebase_Exception::log::104 Zend_Db_Statement_Exception -> SQLSTATE[22021]: Character not in repertoire: 7 FEHLER: ungültige Byte-Sequenz für Kodierung »UTF8«: 0xc2, query was: INSERT INTO "t20_notes" ("note_type_id", "note", "record_id", "record_model", "record_backend", "id", "created_by", "creation_time", "last_modified_by", "last_modified_time", "is_deleted", "deleted_time", "deleted_by", "seq") VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
 41787 eb - 2017-10-31T07:38:08+00:00 WARN (4): Tinebase_Server_Json::_handleException::368 Zend_Db_Statement_Exception -> SQLSTATE[22021]: Character not in repertoire: 7 FEHLER: ungültige Byte-Sequenz für Kodierung »UTF8«: 0xc2, query was: INSERT INTO "t20_notes" ("note_type_id", "note", "record_id", "record_model", "record_backend", "id", "created_by", "creation_time", "last_modified_by", "last_modified_time", "is_deleted", "deleted_time", "deleted_by", "seq") VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
 41787 eb - 2017-10-31T07:38:08+00:00 ERR (3): Tinebase_Exception::log::104 Zend_Db_Statement_Exception -> SQLSTATE[22021]: Character not in repertoire: 7 FEHLER: ungültige Byte-Sequenz für Kodierung »UTF8«: 0xc2, query was: INSERT INTO "t20_notes" ("note_type_id", "note", "record_id", "record_model", "record_backend", "id", "created_by", "creation_time", "last_modified_by", "last_modified_time", "is_deleted", "deleted_time", "deleted_by", "seq") VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)

Server: Debian 8
Database: PSQL

This error seems to be a general problem with PSQL-Database. Log shows many errors like this when trying to cache messages in Felamimail.

Example from Log:
a1219 jürgen - 2017-10-31T08:15:53+00:00 NOTICE (5): Felamimail_Controller_Cache_Message::_addMessageToCache::918 failed to add message to cache: SQLSTATE[22021]: Character not in repertoire: 7 FEHLER: ungültige Byte-Sequenz für Kodierung »UTF8«: 0xe5, query was: INSERT INTO "t20_felamimail_cache_message" ("account_id", "messageuid", "folder_id", "received", "size", "timestamp", "body_content_type", "content_type", "subject", "sent", "from_email", "from_name", "text_partid", "html_partid", "has_attachment", "id") VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, 1, 2, 0, ?)

If necessary, I can provide the respective mail, that causes the error.




TagsNo tags attached.
mwticket

Activities

pschuele

pschuele

2018-03-01 17:31

administrator   ~0021470

pgsql support will be dropped soon.

Issue History

Date Modified Username Field Change
2017-10-31 10:02 apvit New Issue
2017-11-03 10:03 pschuele Assigned To => pschuele
2017-12-07 17:44 pschuele Assigned To pschuele =>
2017-12-07 17:44 pschuele Summary Error "Character not in repertoir" when filing message => Error "Character not in repertoir" when filing message (PGSQL)
2018-01-11 09:57 apvit Category MailFiler => Felamimail
2018-01-11 09:57 apvit Description Updated View Revisions
2018-01-15 08:07 apvit Summary Error "Character not in repertoir" when filing message (PGSQL) => Error "Character not in repertoir" when fileing message (PGSQL)
2018-03-01 17:31 pschuele Note Added: 0021470
2018-03-01 17:32 pschuele Assigned To => pschuele
2018-03-01 17:32 pschuele Status new => closed
2018-03-01 17:32 pschuele Resolution open => won't fix