View Issue Details

IDProjectCategoryView StatusLast Update
0013740Tine 2.0Tinebasepublic2018-03-15 15:03
Reporterlab-at-nohlAssigned Topschuele 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.08.11 Community Edition 
Target Version2018.02.3 Community EditionFixed in Version2018.02.3 Community Edition 
Summary0013740: Reopen Bug 0013512 - Wrong Quota in Admin panel for Cyrus Imap Backend
DescriptionFix is not sufficient. And interferes with other code.
https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/commit/b048d69addd4a65b03cc3bb6cbbddb8ad76f03c0#diff-ba2dd7e24d16e2cebec11e699c65ad41

Mail Quota uses three different units atm.
- IMAP command QUOTA = Kilobytes (RFC822.SIZE, in units of 1024 octets, see RFC 2087)
- Tine 2.0 GUI = Megabytes (full integer means MByte)
- DB and Ldap backends = Bytes

Your fix convert between MByte and Byte only. It works for DB/ldap backends only (on updating cache). It doesn't harm because other backends do not store quota on update cache (they rely only on IMAP-Quota).

Created patch for Cyrus-Backend. Can't estimate effects on others (don't think so):
https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/pull/36
Additional InformationCreate a new ticket because I'm not allowed to reopen existing!
TagsNo tags attached.
mwticket

Relationships

related to 0013512 resolvedpmehrer IMAP Quota miscalculated 

Activities

pschuele

pschuele

2018-03-15 15:03

administrator   ~0021526

pull request has already been merged - thanks for that.

i also allowed reporters to re-open their issues.

Issue History

Date Modified Username Field Change
2018-01-31 20:09 lab-at-nohl New Issue
2018-03-15 15:01 pschuele Target Version => 2018.02.3 Community Edition
2018-03-15 15:01 pschuele Relationship added related to 0013512
2018-03-15 15:03 pschuele Assigned To => pschuele
2018-03-15 15:03 pschuele Status new => resolved
2018-03-15 15:03 pschuele Resolution open => fixed
2018-03-15 15:03 pschuele Fixed in Version => 2018.02.3 Community Edition
2018-03-15 15:03 pschuele Note Added: 0021526