View Issue Details

IDProjectCategoryView StatusLast Update
0013836Tine 2.0ActiveSyncpublic2018-05-03 15:39
ReporterpsiegAssigned Topschuele 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2018.02.3 Community Edition 
Target Version2018.02.4 Community EditionFixed in Version2018.02.4 Community Edition 
Summary0013836: ActiveSync folder type not working for custom Trash folder
DescriptionI am running a setup where the Trash and Sent folders have custom names ('Gelöschte Elemente' from Outlook in German). Felamimail supports these, but reports them incorrectly via ActiveSync because the corresponding check is below the switch (strtoupper($folder->localname)). This effectively allows only custom folders at different locations, say INBOX.something.Trash.
Steps To Reproduce- Setup an account with an E-Mail Account
- Specify a custom Trash folder, such as 'Deleted Items'
- Ensure there is no folder named trash
- Create a corresponding account on your mobile device and log the XML traffic for the FolderHierarchy request:
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE AirSync PUBLIC "-//AIRSYNC//DTD AirSync//EN" "http://www.microsoft.com/">
<FolderSync xmlns="uri:FolderHierarchy">
 <SyncKey>0</SyncKey>
</FolderSync>


Actual Response:
<!DOCTYPE AirSync PUBLIC "-//AIRSYNC//DTD AirSync//EN" "http://www.microsoft.com/">
<FolderSync xmlns="uri:FolderHierarchy" xmlns:Syncroton="uri:Syncroton" xmlns:Internal="uri:Internal">
  <Status>1</Status>
  <SyncKey>1</SyncKey>
  <Changes>
    <Count>41</Count>
    <Add>
      <ServerId>5</ServerId>
      <ParentId>0</ParentId>
      <DisplayName>User Name's personal calendar</DisplayName>
      <Type>8</Type>
    </Add>
    <Add>
      <ServerId>3</ServerId>
      <ParentId>0</ParentId>
      <DisplayName>User Name's personal addressbook</DisplayName>
      <Type>9</Type>
    </Add>
    <Add>
      <ServerId>04828f697f3eb14b2cc6edc4e879be8bb42a1623</ServerId>
      <ParentId>0</ParentId>
      <DisplayName>INBOX</DisplayName>
      <Type>2</Type>
    </Add>
    <Add>
      <ServerId>31e259d55c7a7e01ec6fcf03c0b660bfa0673fc9</ServerId>
      <ParentId>04828f697f3eb14b2cc6edc4e879be8bb42a1623</ParentId>
      <DisplayName>Deleted Items</DisplayName>
      <Type>12</Type>
    </Add>
    <Add>
      <ServerId>fake-3</ServerId>
      <ParentId>0</ParentId>
      <DisplayName>Drafts</DisplayName>
      <Type>3</Type>
    </Add>
    <Add>
      <ServerId>fake-4</ServerId>
      <ParentId>0</ParentId>
      <DisplayName>Trash</DisplayName>
      <Type>4</Type>
    </Add>
    <Add>
      <ServerId>fake-5</ServerId>
      <ParentId>0</ParentId>
      <DisplayName>Sent</DisplayName>
      <Type>5</Type>
    </Add>
    <Add>
      <ServerId>fake-6</ServerId>
      <ParentId>0</ParentId>
      <DisplayName>Outbox</DisplayName>
      <Type>6</Type>
    </Add>
  </Changes>
</FolderSync>

The folder 'Deleted Items' should have Type 4, and there should not be a fake-4 'Trash' folder.


I identified the cause and proposed a fix in https://github.com/tine20/Tine-2.0-Open-Source-Groupware-and-CRM/pull/49
Additional InformationThe E-Mail account is setup with INBOX. personal prefix, i.e. the Trash folder name is 'INBOX.Deleted Items'
Tagsactivesync, felamimail
mwticket

Activities

pschuele

pschuele

2018-05-03 15:39

administrator   ~0021724

pull request has been merged. thanks!

Issue History

Date Modified Username Field Change
2018-04-23 17:19 psieg New Issue
2018-04-23 17:19 psieg Tag Attached: activesync
2018-04-23 17:19 psieg Tag Attached: felamimail
2018-05-03 15:39 pschuele Target Version => 2018.02.4 Community Edition
2018-05-03 15:39 pschuele Assigned To => pschuele
2018-05-03 15:39 pschuele Status new => resolved
2018-05-03 15:39 pschuele Resolution open => fixed
2018-05-03 15:39 pschuele Fixed in Version => 2018.02.4 Community Edition
2018-05-03 15:39 pschuele Note Added: 0021724